Degraded performance of Titan Jobs logs

Incident Report for DNAnexus Inc

Resolved

This incident has been resolved.
Posted Aug 22, 2026 - 08:40 UTC

Update

We have identified the issue (partially related with the previous major outage of the whole platform). We are applying the fix and will continue monitoring the situation.
Posted Aug 22, 2026 - 08:15 UTC

Monitoring

The situation has improved and we are monitoring it.
Posted Aug 22, 2026 - 05:18 UTC

Investigating

We are currently investigating the degraded performance of Titan Jobs logs.
Posted Aug 22, 2026 - 03:49 UTC
This incident affected: Titan Jobs.