Job event processing delays

Incident Report for DNAnexus Inc

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 20:55 UTC

Monitoring

Performance is improving and we are monitoring the event processing status
Posted Apr 16, 2026 - 20:12 UTC

Investigating

We are investigating an issue with delays in Titan job event processing
Posted Apr 16, 2026 - 15:32 UTC
This incident affected: Titan Jobs.