Platform API slow response times
Incident Report for DNAnexus Inc
Resolved
This incident has been resolved.
Posted Jul 11, 2023 - 11:44 PDT
Monitoring
API response times have recovered and we're monitoring.
Posted Jul 11, 2023 - 11:14 PDT
Investigating
Investigating slow API response times.
Posted Jul 11, 2023 - 10:53 PDT
This incident affected: Titan API.