Degraded performance and increased error rate

Incident Report for DNAnexus Inc

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 21:07 UTC

Update

We are seeing services return to normal and will continue monitoring closely.

Users may now resume their activities
Posted Oct 20, 2025 - 19:33 UTC

Update

All regions are currently affected.
Posted Oct 20, 2025 - 16:36 UTC

Monitoring

All non us-east-1 regions are fully operational.

We are still affected by the cloud provider outage in us-east-1 region that can result in job assignment delays.
Posted Oct 20, 2025 - 12:59 UTC

Update

All non us-east-1 regions are fully operational.

We are still affected by the cloud provider outage in us-east-1 region that can result in job assignment delays.
Posted Oct 20, 2025 - 12:55 UTC

Update

The cloud provider is making progress in resolving the issue and we're seeing improved performance. However, Titan jobs are still affected.
Posted Oct 20, 2025 - 11:05 UTC

Identified

We are seeing issues in our platform that are related to the outage of our cloud provider.
Posted Oct 20, 2025 - 10:06 UTC
This incident affected: Titan UI, Titan API, Titan Jobs, Titan Data, Apollo, and UKB RAP.