Elevated API Response Times

Incident Report for DNAnexus Inc

Resolved

API response times are no longer elevated.
Posted Oct 27, 2023 - 18:28 UTC

Investigating

We are investigating elevated API response times.
Posted Oct 27, 2023 - 18:16 UTC
This incident affected: Titan API.