Degraded platform performance in AWS me-south-1 region

Incident Report for DNAnexus Inc

Resolved

This incident has been now resolved; our services in AWS me-south-1 region are operational.
Posted Mar 02, 2026 - 15:36 UTC

Investigating

We are experiencing a degraded performance in AWS me-south-1 region due to issues at the cloud provider side.
Posted Mar 02, 2026 - 07:10 UTC
This incident affected: Titan Jobs and Titan Data.