Job assignment delays

Incident Report for DNAnexus Inc

Resolved

This incident has been resolved.
Posted Mar 23, 2024 - 13:53 UTC

Investigating

Investigating delays in job assignment.
Posted Mar 23, 2024 - 13:25 UTC
This incident affected: Titan Jobs.