Degraded performance of Azure WestUS region

Incident Report for DNAnexus Inc

Resolved

The incident has been resolved on the cloud provider side.
Posted Sep 07, 2026 - 17:58 UTC

Identified

Some customers can experience issues when starting new jobs in Azure WestUS region due to the issue on the cloud provider side.
Posted Sep 07, 2026 - 13:59 UTC
This incident affected: Titan Jobs.