Platform Outage

Incident Report for DNAnexus Inc

Resolved

This incident has been resolved.
Posted Aug 21, 2026 - 17:27 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 21, 2026 - 17:27 UTC

Monitoring

We identified the issue and the fix is delivered. We're monitoring it.
Posted Aug 21, 2026 - 17:15 UTC

Update

We are continuing to investigate this issue.
Posted Aug 21, 2026 - 16:58 UTC

Update

We are continuing to investigate this issue.
Posted Aug 21, 2026 - 16:57 UTC

Investigating

We are currently investigating the outage of our platform.
Posted Aug 21, 2026 - 16:56 UTC
This incident affected: Titan UI, Titan API, Titan Jobs, Titan Data, and Apollo.