Degraded performance in Azure westus region

Incident Report for DNAnexus Inc

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 19:38 UTC

Investigating

We are currently investigating degraded performance in Azure westus region.
Posted Jul 23, 2026 - 15:28 UTC
This incident affected: Titan Jobs and Titan Data.