Investigating job scheduling delays

Incident Report for DNAnexus Inc

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 18:05 UTC

Update

Job scheduling should be back to normal. The delays were related to AWS EC2 instance launch issues. AWS took steps to mitigate the incident.
Posted Oct 28, 2025 - 18:04 UTC

Investigating

We are currently investigating job scheduling delays.
Posted Oct 28, 2025 - 17:18 UTC
This incident affected: Titan Jobs.