Unarchived file download

Incident Report for DNAnexus Inc

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 18:21 UTC

Identified

We have identified the issue, file archival and unarchival should now be operating. Files which have been unarchived in the past day may still be inaccessible.

We continue to investigate and will post another update when available.
Posted Mar 26, 2026 - 01:33 UTC

Investigating

We are currently investigating this issue.
Posted Mar 25, 2026 - 23:50 UTC
This incident affected: Titan Data.