Investigating platform outage
Incident Report for DNAnexus Inc
Resolved
This incident has been resolved.
Posted Oct 27, 2023 - 17:48 PDT
Investigating
We are currently investigating this issue.
Posted Oct 27, 2023 - 17:36 PDT
This incident affected: Titan UI, Titan API, Titan Jobs, Titan Data, Apollo, and UKB RAP.