Investigating Elevated API Response Times

Incident Report for DNAnexus Inc

Resolved

This incident has been resolved.
Posted Jan 28, 2025 - 05:29 UTC

Update

We are continuing to investigate this issue.
Posted Jan 28, 2025 - 05:28 UTC

Investigating

We are currently investigating this issue.
Posted Jan 28, 2025 - 05:00 UTC
This incident affected: Titan UI, Titan API, Titan Jobs, Titan Data, Apollo, and UKB RAP.