Elevated API response times

Incident Report for DNAnexus Inc

Resolved

API response times have recovered.
Posted Sep 05, 2023 - 22:45 UTC

Investigating

We're currently investigating elevated API response times.
Posted Sep 05, 2023 - 22:21 UTC
This incident affected: Titan API.